Server Requirements

The server requirements for Commerce are the same as Craft 3.1 but with the following additions

PHP package dependencies

craftcms/cms ^3.1
dompdf/dompdf ^0.8.2
moneyphp/money ^3.1.3
dannyvankooten/vat.php ^1.1.2
phpoffice/phpspreadsheet ^1.4

GD Image Extension

Required for PDF generation.